Quantum Scalar i6000 Drive
Replacement

Use this procedure to replace a tape drive in a Scalar i6000 library.

If a drive fails, the library will issue a ticket. From the Details screen, write down
the Repair Link or Error Code number. You'll need it when you contact
Quantum Service.

WARNING: Before performing any of the steps listed in this document,
contact Quantum Service for help diagnosing the problem.

WARNING: To use this procedure, all drives must be connected to an Ethernet
Expansion Blade (EEB) or an FC I/O blade.

Refer to the following sections and follow the steps in the document to replace
a drive in your Scalar i6000 library:

* Locating a Drive on page 2
* Remove and Replace the Drive on page 4

* Update the Drive Firmware Using Firmware Images on page 8
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Locating a Drive

When a drive fails, a ticket is generated by the library that will identify the
malfunctioning drive using a coordinate system. This section will explain the
basics of locating a drive using the coordinate system so when you are replacing
the drive, you will be able to identify the correct drive. Removing a drive
incorrectly can impact data on your library.

The drive coordinate system has six (6) numbers, for example: 1,2, 1,7, 1, 1.
The first number identifies the aisle. The Scalar i6000 is a single aisle library only
so this number is always 1.

Sample Coordinate: @2 1711

Aisle

1

The second number identifies the module. The module number can be from 1-
16. This applies to both single- and dual-robot libraries. The left parking module
(module 0) is only for dual-robot libraries and cannot contain drives. A high-
density expansion module (HDEM) also cannot contain drives.

Sample Coordinate: 1@1 711

Aisle | Module
1 1-16

© o ® 06 ® 6 ® 0o 6 6 GO O ®

[ Single-Robot Library |

| Dual-Robot Library |
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The third number in the sequence represents the rack. Since drives can only be
contained in rack 1, this number will always be 1.

Sample Coordinate: 1 2@7 11

Aisle | Module | Rack
1 1-16 1

The fourth number indicates the section. Each module can contain 12 drives so
with drives, this number can range from 1-12. Drives are counted from bottom
to top.

Sample Coordinate: 1 2 1@1 1

Aisle | Module Rack Section
1 1-16 1 1-12

QICISICICIONSICIOISISIS)

The fifth number in the sequence identifies the column. Since drives can only be
contained in a single column, they will always reside in column 1.

Sample Coordinate: 1 2 1 7@1

Aisle | Module | Rack | Section | Column

1 1-16 1 1-12 1
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The sixth number denotes the row and will always be 1. Drives have a

connection point at the lower portion of the drive sled that connects to the
library. Therefore, the sled is logically in row 1.

Sample Coordinate: 1 2 1 7 1@

Aisle | Module Rack Section | Column Row

1 1-16 1 1-12 1 1

Remove and Replace the Drive

Note: This procedure is used to replace a drive with the same drive model.
Drive upgrades must be performed by Quantum service personnel. If
the failed drive is an EDLM drive, it must be replaced by Quantum
service personnel.

Caution: Before starting this procedure, verify that you have received the
same make and model drive as the drive you are replacing. The
outside of the box will indicate the drive make and model that was
shipped.

Required tool: Phillips screwdriver - use this if the thumbscrews are too tight

1 Stop any processes on the host that are communicating with the drive that
is being replaced.

2 Log on as the administrator from the library’s touch screen (LMC).

3 Locate the drive identified as needing replacement on your call with
Quantum Service:

a Select View > Physical Library.

b Select Tools > Drives. The Drives screen displays.

4 Remove and Replace the Drive
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B Drives _asiB a ' B —
~Drive(s)
Drive Type: |ALL -

State | DriveType| Location | RAS |  wwwiscsiiD | Volser| Partition Name
VariedOn |LTO3-FC [1,1,1,3,1,1 |Good  |500308c0:014d500d A
VariedOn LTO3-FC [1,1,1,4 1,1 |Warning |500308c0:014d5013 Logical Library 01 |F|
VariedOn |LTOB-FC [1,1,1,5,1,1 |Good  |500308c0:014d5019 part A
VariedOn |LTO6-FC [1,1,1,6,1,1 |Warning |500308¢0:014d501f part A

] ]

( )6 )6 )6 )
( I I I )
( )(_cmen J(_rerem J(_rop

¢ Using the coordinates, select the drive to be replaced.

d Scroll over to the Firmware Version column.

B Drives _as a s B e
rDrive(s)
Drive Type: | ALL -
jon | RAs | wwwiscsiiD | volser| ParionName | Serial# | Firmware version
1,1 |Good  |500308c0:014d500d F0D14D500D |M23A
1,1 |Warning |500308c0:014d5013 Logical Library 01 |F0D14D5013 [93GH
1,1 (Good  |500308c0:014d5019 part F0D14D5019 |J39Z
1,1 |Warning |500308c0:0140501f part FOD14D501F |J38W
[«

rControl
[ Power Cycle ] L Reset Drive ] L Vary Off ] L ldentify ]
[ Self Test ] L J L Get Drive Log ] L Clean ]

[ Details... ] L Cancel ] L Refresh ] L Help ]

e Write down the four digit firmware level.
4 Click Cancel to close the Drives screen.

5 Double check that there is no tape in the drive you are removing. If there is
a cartridge in the tape drive:

a Select View > Partition. You will select the partition that contains the
drive you are replacing.

b Select Operations > Drives > Unload. This will eject the tape from the
drive and return it in its storage slot in the library.

Note: If a tape is in the drive and cannot be ejected, call Quantum
support before proceeding.

6 Go back to library view by selecting View > Physical Library.
7 Select Tools > Drives. The Drives screen displays.
8 Vary off the drive:

a From the Drives screen, use the Drive Type drop-down menu to display
the drives by drive type.

b Select the drive, and then click Vary Off.

Remove and Replace the Drive 5
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¢ Click Yes.

B Warning! @

This operation could cause loss of data.

: Do you want to continue?

[ Yes ] L Mo ]

d Go to the rear of the module containing the drive to be replaced, open
the back door, locate the drive using the coordinates from the ticket and
observe the blue LED on the rear of the drive. When the blue LED stops
blinking and remains constantly lit, you can continue.

Green Port LED 1 Blue LED

Amber LED

Guide Rail

Thumbscrews Drive Handle

9 Disconnect all cables from the drive. Note which cables go to which
connections for reference during drive replacement.

10 Loosen the two thumbscrews on the drive.
11 Grip the drive handle and pull the drive toward you to remove it.
12 Use the guide rails on the replacement drive to slowly slide it in until flush.
13 Tighten the two thumbscrews.
14 Reconnect the cables.
15 Confirm the following status LEDs:
a Blue LED light on the back of the drive is constantly lit

b Green LED 2 light on the back of the drive is blinking slowly and in
cadence with the LEDs on the other drives

Note: The LEDs should take less than 5 minutes to get to this state.

6 Remove and Replace the Drive



Quantum Scalar i6000: Drive Replacement
6-67999-01 Rev A
October 2013

16 If the LEDs are displaying properly, you can vary on the drive. From the
Drives screen:

a Select the newly installed drive.
b Click the Vary On button.
c Click Cancel.

17 The library may update the drive sled firmware. Wait a few minutes to see if
a dialog box appears. If this happens, wait until it is complete before
continuing. The drive sled firmware update will take approximately 5
minutes.

18 Go to the rear of the module and observe the drive status LEDs and wait for
the following conditions to occur:

* Green LED 1 - solid green indicating port connectivity to either the
FC I/O blade or the customer FC switch

e Amber LED - off

* Blue LED - blinks one time per 10 seconds

* Green LED 2 - blinks at the same cadence as the other green LEDs on
the other drives in the module

Green Port LED 1 Blue LED

Amber LED

19 Close the access doors.

20 Close the ticket that was generated for the failed drive.
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Update the Drive Firmware Using Firmware Images

Note: This procedure should only be used if drive auto-leveling is turned off.

Note: If you are viewing a partition, drive firmware update operations affect
drives that are within the partition only.

Note: You can only perform firmware updates for drives of the same product,
such as IBM LTO-4 or HP LTO-5.

Caution: If you load a firmware image onto a drive that is the same version
that is currently running on the drive, the upgrade will fail.

1 From the View menu, select the partition that contains the replacement

drive.

B Scalar i6000 Library Management Console - user: admin

o o

Operations Monitor Setup Tools

View | Connection Help

ol

Name: Physical Library: CBL
IP Address: 10.20.171.39
Contact: N/A

Activity: 1dle

| JE

r System Information—————

CBL (Physical)

Logical Library 01 (Partition)
par1 (Partition)

=

X

LOG OFF

Views...

Physical Serial #:

Date: Thu, 01 Aug 2013 15:37:09 GMT

Status: Online
203100338

2 Select Tools > Update Software > Drives. A warning dialog box displays
stating the partition needs to be taken offline.

= B S

2

@ partition.

Status: Online
203100338
13 15:39:16 GMT

B Scalar i6000 Library Management Console - user: admin
Operations Monitor Setup Tmls| View Connection Help
Tickets...
o | | D
IWE IMPORT EXPORT Drives... 3‘%’5{4‘
I )| Connectivity...
r System Information —— Capture Snapshot...
Mame: Physical Library; CBL| Update Software M Library...
IP Address: 10.20.171.39 | Teach... Drives...
Contact: N/A Save/Restore... Plug-in...
Activity: Idle Verification Tests... |
- . o
-
B Warning!

—

The Partition must be taken offline prior to performing the operation. Changing
partition mode to offline will cause all robotic actions against this partition
to fail, please ensure all backup applications are not currently using this

Do you want to take the Partition offline now?

Yes

J L
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4 From the Update Drive Firmware screen, ensure the option selected in the
Update Method area is set to Firmware Image.

B Update Drive Firmware‘ !_ i ! A e | ": i = &J
To update fi the must be true. You will not be able to select the drive otherwise.
1. Varied On
2. Empty
3. Autolevel Disabled
Update Method
{ ® Firmware Image |_) FMR Tape L J
Product Id | SN# Type | Firmware Location | 9
[_1 HP Ultrium 6-5CS1 |FO014D5019  [LTOG-FC J397 1,1,1,5 1,1
[¥] HP Ultrium 6-5CS1 FOO14D501F  LTOG-FC J3sw 1,1,1,6, 1,1
v ]
elect Firmware File
|HP_LTO6_J392E ~ | Manage Images.. |
(st [ selectar || ciose | Hep ]

Click the check box next to

the replacement drive.

Compare the four digit firmware level you wrote down earlier with the four

digit firmware version listed in the Firmware column of the selected drive. If

they match, go to step 12.

you want to install.

If not, continue on to step 7.

From the Select Firmware File drop-down menu, select the firmware image

J

Manage Images...

Select Firmware File
HP_LT05_J30zE |

HP_LTOB_J39ZE |
( stan

J [ seleaan ||

Close ] L Help ]

The drop-down list includes all drive firmware images that are currently
stored on the library, regardless of drive type. Be careful to select a drive
firmware image that is compatible with the type of drive that you want to
update. See the library's Release Notes for compatibility information or
contact Quantum technical support.

For details on downloading drive firmware, see Chapter 15, Maintaining
Your Library - Maintenance Actions in the Scalar i6000 User’s Guide.

canceled.

Click Start. A warning dialog box displays stating the operation cannot be

B Warning!

]

@ Operation can not be canceled - do you want to continue?

J

9 Click Yes. The library automatically logs off other users so they cannot

perform library operations

while the drive firmware update is in progress.

Update the Drive Firmware Using Firmware Images
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Note: On the back of the drive, the Green LED 2 will flash rapidly while
the firmware update is in progress.

10 The library updates the firmware on the selected drive.

Note: Updating drive firmware could take up to 20 minutes to complete.

11 When finished, the Status column of the drive will state Update Complete
and the LEDs on the back of the drive will display:

* Green LED 1 - solid green indicating port connectivity to either the
FC I/O blade or the customer FC switch

* Amber LED - off
* Blue LED - blinks one time per 10 seconds

* Green LED 2 - blinks at the same cadence as the other green LEDs on
the other drives in the module

12 Click Close.
13 Select View > Views. The Manage Views screen displays.
r. Manage Views @1

CBL (Physical) ] onine |

Logical Library 01 (Partit.. | Onine |

pard (Partition) ) oftine |

( N
Close

.

14 Click the Offline button for the partition that contains the replacement
drive. The Change Library Mode screen displays.

 Change Library Mo
Current Library Mode: Offline
Mode
) [Online ) Offline
W L J L Cancel ] L Help ]

15 In the Mode area on the Change Library Mode screen, select Online and
click OK. The Manage View dialog shows the partition now Online.

[ . Manage Views ﬁ
CBL (Physical) ] onine |
Logical Library 01 (Partit.. | Onine |
pard (Partition) . onine |

( N
Close

16 Click Close.

10 Update the Drive Firmware Using Firmware Images
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17 From your applications, bring the replacement drive online and perform any
necessary tests to ensure it is working properly.

18 Call Quantum Service to confirm that drive replacement was successful and
to perform any further troubleshooting.

Note: When the drive replacement is complete, refer to the documentation
that was included in the drive packaging for how to return the failed

drive to Quantum.

Update the Drive Firmware Using Firmware Images
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